summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-07 15:08:07 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-29 00:14:21 +0200
commit96652637ccfd94442224019c54341bf86094366a (patch)
tree437e3514ee87e5eda77508514e12864a0542af00 /linux/linux.mk
parentb626dc0791002d61f47c53b619fcba048c40171d (diff)
linux: fix uImage location on AVR32
On most architectures, the kernel image can be found in arch/<ARCH>/boot, but on AVR32, it's in arch/<ARCH>/boot/images. Issue initially reported by Joachim Pihl <joachim.pihl@sensordevelopments.com>. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 4490023a4..55dc2bfe8 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -42,7 +42,11 @@ else ifeq ($(BR2_LINUX_KERNEL_VMLINUX_BIN),y)
LINUX26_IMAGE_NAME=vmlinux.bin
endif
+ifeq ($(KERNEL_ARCH),avr32)
+LINUX26_IMAGE_PATH=$(LINUX26_DIR)/arch/$(KERNEL_ARCH)/boot/images/$(LINUX26_IMAGE_NAME)
+else
LINUX26_IMAGE_PATH=$(LINUX26_DIR)/arch/$(KERNEL_ARCH)/boot/$(LINUX26_IMAGE_NAME)
+endif
# Download
$(LINUX26_DIR)/.stamp_downloaded: