summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-08 04:27:06 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-11 22:57:07 +0100
commitb7a2358f0babe29219f3e2956eae53603b4a7f2c (patch)
tree2895495133a8a20d23de5c3a62e91bbdc216a4ff /linux/linux.mk
parent6f955df42d27f9afe7a9a1a43d0a4095a95c1286 (diff)
linux: restore DEPMOD usage
The linux.mk rewrite lost the DEPMOD setting while installing modules which means depending on host-module-init-tools has been useless. Instead, the build system has been executing /sbin/depmod. While we're here, drop the INSTALL_MOD_PATH since LINUX26_MAKE_FLAGS already contains it. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 5f89b7dd3..e9c37ebc7 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -132,7 +132,7 @@ $(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
# directories, not relevant on the target
@if [ $(shell grep -c "CONFIG_MODULES=y" $(LINUX26_DIR)/.config) != 0 ] ; then \
$(TARGET_MAKE_ENV) $(MAKE1) $(LINUX26_MAKE_FLAGS) -C $(@D) \
- INSTALL_MOD_PATH=$(TARGET_DIR) modules_install ; \
+ DEPMOD="$(HOST_DIR)/usr/sbin/depmod" modules_install ; \
rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION_PROBED)/build ; \
rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION_PROBED)/source ; \
fi