summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorMartin Hicks <mort@bork.org>2011-02-01 12:13:00 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-01 20:51:15 +0100
commitd10e46fb7623673b590faac2a90dccea475a7e3e (patch)
treea51bdb376da3ccd753a723111dfef84e1dec9e28 /linux/linux.mk
parentb823c04d080016b28c955240ec634764718041bd (diff)
Enable ccache for kernel compile
Just needed to pass in ccache as a prefix to the CROSS_TARGET variable. Signed-off-by: Martin Hicks <mort@bork.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index d3c06db4b..2bc2efe16 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -23,7 +23,7 @@ LINUX26_MAKE_FLAGS = \
HOSTCFLAGS="$(HOSTCFLAGS)" \
ARCH=$(KERNEL_ARCH) \
INSTALL_MOD_PATH=$(TARGET_DIR) \
- CROSS_COMPILE=$(TARGET_CROSS) \
+ CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \
LZMA="$(LZMA)"
# Get the real Linux version, which tells us where kernel modules are