summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-05 21:53:17 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-16 22:25:32 +0100
commitfb358f7b38866b7e48ecc58b1a1f59c1aa95ce44 (patch)
treed12371adaa2fc5fe598919d4da85cc8a6377f318 /linux/linux.mk
parent32a8c0119fce072ea9c91bcf40dcd5c912662fb5 (diff)
linux: Import minimal defconfigs as defconfigs
Now that minimal kernel defconfigs are used in Buildroot, the problem is that copying those minimal configuration files to .config in the kernel source tree does not work, as kconfig will ask interactively what should be the value for all unspecified options. On suggestion on Sam Ravnborg, the easiest way to solve this is to import the minimal defconfig file as a defconfig inside the kernel tree (in arch/$(ARCH)/configs) and configure the kernel with it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index e9c37ebc7..639e4cee9 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -86,7 +86,9 @@ $(LINUX26_DIR)/.stamp_configured: $(LINUX26_DIR)/.stamp_patched
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
$(TARGET_MAKE_ENV) $(MAKE1) $(LINUX26_MAKE_FLAGS) -C $(@D) $(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG))_defconfig
else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
- cp $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE) $(@D)/.config
+ cp $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE) $(@D)/arch/$(KERNEL_ARCH)/configs/buildroot_defconfig
+ $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX26_MAKE_FLAGS) -C $(@D) buildroot_defconfig
+ rm $(@D)/arch/$(KERNEL_ARCH)/configs/buildroot_defconfig
endif
ifeq ($(BR2_ARM_EABI),y)
$(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config)