summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-30 10:21:40 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-30 10:21:40 +0200
commit074b6689e81d5bc4abf08d63dc8086b9cc41a078 (patch)
tree8cff99d679b7260a54cebac38af0764b16394b71 /linux
parent18abd4aa94cd59240b90257c95877c0ea2fd1796 (diff)
parente7584697f24d0bc6fc660703d97a38598cb76690 (diff)
Merge branch 'fixes-20100729' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index a3e5a0c02..3fc259c22 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -160,3 +160,16 @@ linux26-rebuild-with-initramfs: $(LINUX26_DIR)/.stamp_initramfs_rebuilt
ifeq ($(BR2_LINUX_KERNEL),y)
TARGETS+=linux26
endif
+
+# Checks to give errors that the user can understand
+ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
+$(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)
+endif
+endif
+
+ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)),)
+$(error No kernel configuration file specified, check your BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE setting)
+endif
+endif \ No newline at end of file