summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-07-11 22:46:11 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-11 23:40:49 +0200
commit205fb19cdb475b0b56e675f53bdeca17deb98fbe (patch)
tree74f3d7d02a6d466bef7a636d0270f0cfe95c763c /linux
parentb0d446dee427cfdb71c55c2a46472786de7b8ffc (diff)
linux: allow specification of a custom Git repository as a source
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in15
-rw-r--r--linux/linux.mk3
2 files changed, 18 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index bf16ddf2b..8d3b0ba84 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -47,6 +47,12 @@ config BR2_LINUX_KERNEL_CUSTOM_TARBALL
This option allows to specify the http or ftp location of a
specific kernel source tarball
+config BR2_LINUX_KERNEL_CUSTOM_GIT
+ bool "Custom Git tree"
+ help
+ This option allows Buildroot to get the Linux kernel source
+ code from a Git repository.
+
endchoice
config BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE
@@ -58,12 +64,21 @@ config BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION
string "URL of custom kernel tarball"
depends on BR2_LINUX_KERNEL_CUSTOM_TARBALL
+config BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL
+ string "URL of custom Git repository"
+ depends on BR2_LINUX_KERNEL_CUSTOM_GIT
+
+config BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION
+ string "Custom Git version"
+ depends on BR2_LINUX_KERNEL_CUSTOM_GIT
+
config BR2_LINUX_KERNEL_VERSION
string
default "2.6.39.3" if BR2_LINUX_KERNEL_2_6_39
default BR2_DEFAULT_KERNEL_HEADERS if BR2_LINUX_KERNEL_SAME_AS_HEADERS
default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE if BR2_LINUX_KERNEL_CUSTOM_VERSION
default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
+ default $BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION if BR2_LINUX_KERNEL_CUSTOM_GIT
#
# Patch selection
diff --git a/linux/linux.mk b/linux/linux.mk
index 25db1f5ea..bba49216c 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -10,6 +10,9 @@ ifeq ($(LINUX_VERSION),custom)
LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))
LINUX_SITE = $(dir $(LINUX_TARBALL))
LINUX_SOURCE = $(notdir $(LINUX_TARBALL))
+else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
+LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_GIT_REPO_URL))
+LINUX_SITE_METHOD = git
else
LINUX_SOURCE = linux-$(LINUX_VERSION).tar.bz2
LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v2.6/