summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2011-09-17 22:22:51 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-18 22:59:20 +0200
commit3011d235185b490e619dd8b01004538c5985b0ed (patch)
tree08acdcd0793b47a24f19f7328f1e334bdd4fc60f /linux
parentad1fd9778566e9020ace3b8c7d2b3815b67201b4 (diff)
linux: Add Linux Kernel extensions menu
Add a kernel sub-menu (called "Linux Kernel Extensions"), which makes possible to patch it or tweak the kernel build step. * All linux/linux-ext-*.mk files will be read by the make process. * The menu can be customized in "linux/Config.ext.in". [Peter: small fixes] Signed-off-by: Benoit Mauduit <benoit.mauduit@openwide.fr> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.ext.in3
-rw-r--r--linux/Config.in4
-rw-r--r--linux/linux.mk2
3 files changed, 9 insertions, 0 deletions
diff --git a/linux/Config.ext.in b/linux/Config.ext.in
new file mode 100644
index 000000000..50e801d67
--- /dev/null
+++ b/linux/Config.ext.in
@@ -0,0 +1,3 @@
+menu "Linux Kernel Extensions"
+
+endmenu
diff --git a/linux/Config.in b/linux/Config.in
index 537cb54cc..56552867f 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -176,6 +176,10 @@ config BR2_LINUX_KERNEL_INSTALL_TARGET
/boot in the target root filesystem, as is typically done on
x86/x86_64 systems.
+
+# Linux extensions
+source "linux/Config.ext.in"
+
endif # BR2_LINUX_KERNEL
endmenu
diff --git a/linux/linux.mk b/linux/linux.mk
index d289b2842..f249d9670 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -177,6 +177,8 @@ define LINUX_INSTALL_TARGET_CMDS
fi
endef
+include linux/linux-ext-*.mk
+
$(eval $(call GENTARGETS,,linux))
linux-menuconfig linux-xconfig linux-gconfig linux-nconfig linux26-menuconfig linux26-xconfig linux26-gconfig linux26-nconfig: dirs $(LINUX_DIR)/.stamp_configured