summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-28 14:43:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-28 14:43:25 +0200
commit3e5e39a8a25a4a085afe08bdcf46933c8d569ed7 (patch)
tree6ca06946f1655570924faae9934179c4dc314208 /linux
parenta70d443483b360a0cc0ca1759e9a410b7855dbe8 (diff)
barebox/u-boot/linux: don't error out on missing config when make source
As it breaks 'make allyesconfig; make source', used for the source mirror. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ea338fc5c..aabecc1f6 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -159,6 +159,7 @@ TARGETS+=linux26
endif
# Checks to give errors that the user can understand
+ifeq ($(filter source,$(MAKECMDGOALS)),)
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
$(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)
@@ -169,4 +170,6 @@ ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)),)
$(error No kernel configuration file specified, check your BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE setting)
endif
-endif \ No newline at end of file
+endif
+
+endif