summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-08-31 23:35:04 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-17 08:15:32 +0200
commit59a326b934737483531c49c99acda7874c72e335 (patch)
tree37535beb370ab735f84fe06ff641da3720211fce /linux
parent20f8a7dec6fc25f6c475163c0273147580128867 (diff)
support: move patch-kernel.sh and rename it
The name "patch-kernel.sh" is a bit stupid, since this script is used to patch everything in Buildroot, not only kernel trees. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 6662f7b06..d289b2842 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -100,11 +100,11 @@ LINUX_POST_DOWNLOAD_HOOKS += LINUX_DOWNLOAD_PATCHES
define LINUX_APPLY_PATCHES
for p in $(LINUX_PATCHES) ; do \
if echo $$p | grep -q -E "^ftp://|^http://" ; then \
- toolchain/patch-kernel.sh $(@D) $(DL_DIR) `basename $$p` ; \
+ support/scripts/apply-patches.sh $(@D) $(DL_DIR) `basename $$p` ; \
elif test -d $$p ; then \
- toolchain/patch-kernel.sh $(@D) $$p linux-\*.patch ; \
+ support/scripts/apply-patches.sh $(@D) $$p linux-\*.patch ; \
else \
- toolchain/patch-kernel.sh $(@D) `dirname $$p` `basename $$p` ; \
+ support/scripts/apply-patches.sh $(@D) `dirname $$p` `basename $$p` ; \
fi \
done
endef