summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorYegor Yefremov <yegor_sub1@visionsystems.de>2010-09-30 14:57:53 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-09 14:20:03 +0200
commit726b15f64a10b2886c9b1bfe484f4cc7a71ea79e (patch)
tree76c63c4d00a9202e54a30421a4818c2c454e1051 /linux
parentc59d0247541a85c62227b79d4fdb77405c4e6c99 (diff)
Create menu entry to select device creation method
Four methods for the creation of device files in /dev are now proposed: - static method uses device table as before - devtmpfs method enables this feature in kernel - mdev method adds mdev starting script to the file system and selects mdev itself for installation - udev method selects udev for installation All dynamic methods are based on devtmpfs, so one doesn't need to care about /dev folder. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 90dc1dcb9..43ca87b9f 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -134,6 +134,13 @@ ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
$(call KCONFIG_DISABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_NONE,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config)
endif
+ifneq ($(BR2_ROOTFS_DEVICE_CREATION_STATIC),y)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config)
+endif
+ifeq ($(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),y)
+ $(call KCONFIG_SET_OPT,CONFIG_UEVENT_HELPER_PATH,\"/sbin/mdev\",$(@D)/.config)
+endif
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
$(Q)touch $@