summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-22 19:50:17 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-22 22:19:30 +0100
commite88704dfba3209b093c7f4767d272972c3b911e1 (patch)
treef3049179804c893f477f2871cf4707c47368d73b /linux
parentc5a195e4038af111fafc452e030e2a0a83ec1d9e (diff)
linux: don't force IPv6 configuration in kernel
As per the discussion at http://lists.busybox.net/pipermail/buildroot/2010-December/040030.html, remove the bits that forced the IPv6 configuration in the kernel depending on the toolchain ability to support (or not) IPv6. You may have a toolchain with IPv6 support but still don't want to have IPv6 in your kernel. The only parameters we adjust in the kernel configuration are: * ARM EABI, since we got a lot of bug reports regarding misconfigured kernel compared to the ABI used by userspace applications. * initramfs, since its contents are generated by Buildroot itself Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index f2c6fd512..f81ff5c1e 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -112,11 +112,6 @@ ifeq ($(BR2_ARM_EABI),y)
else
$(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config)
endif
-ifeq ($(BR2_INET_IPV6),y)
- $(call KCONFIG_ENABLE_OPT,CONFIG_IPV6,$(@D)/.config)
-else
- $(call KCONFIG_DISABLE_OPT,CONFIG_IPV6,$(@D)/.config)
-endif
ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
# As the kernel gets compiled before root filesystems are
# built, we create a fake initramfs file list. It'll be