summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 23:15:47 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-15 21:17:35 +0200
commitee3f319249e146d92b093ad8c45a3a908d44236f (patch)
treec0e726fbc8e32d3be51c15b2a839756c273fa32c /linux
parentaa87ac99c56750eb5d626a785169e6df5407cc96 (diff)
linux: don't force no initramfs
When initramfs was not selected as a root filesystem, we forcefully disabled the initramfs in the kernel configuration. However, it prevents an user from manually managing its initramfs, as we override the option he has set in his kernel configuration file. There's no real reason to do so: when initramfs is not selected as the root filesystem, just don't touch initramfs related options in the kernel configuration. Problem reported by Sergey Naumov <sknaumov@gmail.com>. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 3fc259c22..ea338fc5c 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -104,9 +104,6 @@ ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
$(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.initramfs\",$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config)
-else
- $(call KCONFIG_DISABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
- $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"\",$(@D)/.config)
endif
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
$(Q)touch $@