summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-07-05 21:53:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-07 23:16:05 +0200
commiteff25f4cca89d816665de469b7164267aaf52d4b (patch)
treebf9f1ec16e5a479c40600e9548d39491b538491a /linux
parent4ca599360235ac16cea940bdb2aa9dc3393dbce3 (diff)
linux: make it possible to install the kernel in /boot
[Peter: always copy to output/images as requested by Luca] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in8
-rw-r--r--linux/linux.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 1f1a69c44..bdfa5b7ef 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -153,6 +153,14 @@ config BR2_LINUX_KERNEL_IMAGE_TARGET_NAME
Specify the kernel make target to build the kernel that you
need.
+config BR2_LINUX_KERNEL_INSTALL_TARGET
+ bool "Install kernel image to /boot in target"
+ depends on !BR2_TARGET_ROOTFS_INITRAMFS
+ help
+ Select this option to have the kernel image installed to
+ /boot in the target root filesystem, as is typically done on
+ x86/x86_64 systems.
+
endif # BR2_LINUX_KERNEL
endmenu
diff --git a/linux/linux.mk b/linux/linux.mk
index 43ca87b9f..a5b9b8e2e 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -157,6 +157,9 @@ $(LINUX26_DIR)/.stamp_compiled: $(LINUX26_DIR)/.stamp_configured $(LINUX26_DIR)/
# Installation
$(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
@$(call MESSAGE,"Installing kernel")
+ifeq ($(BR2_LINUX_KERNEL_INSTALL_TARGET),y)
+ install -m 0644 -D $(LINUX26_IMAGE_PATH) $(TARGET_DIR)/boot/$(LINUX26_IMAGE_NAME)
+endif
cp $(LINUX26_IMAGE_PATH) $(BINARIES_DIR)
# Install modules and remove symbolic links pointing to build
# directories, not relevant on the target