summaryrefslogtreecommitdiff
path: root/make/autoconf.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
commit1fc3f2f3de0f731c2869a48f951557eed6704218 (patch)
treee5fa011e92f78d0feab200dde260ba21561e76d0 /make/autoconf.mk
parent36830baea210bba2490f643a1d147bf9adb2b62b (diff)
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'make/autoconf.mk')
-rw-r--r--make/autoconf.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/make/autoconf.mk b/make/autoconf.mk
index fe11b2c7d..2332f546a 100644
--- a/make/autoconf.mk
+++ b/make/autoconf.mk
@@ -21,9 +21,11 @@ $(AUTOCONF_DIR)/.unpacked: $(DL_DIR)/$(AUTOCONF_SOURCE)
$(AUTOCONF_DIR)/.configured: $(AUTOCONF_DIR)/.unpacked
(cd $(AUTOCONF_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) EMACS="no" \
+ $(TARGET_CONFIGURE_OPTS) EMACS="no" \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \