summaryrefslogtreecommitdiff
path: root/make/ccache.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-04-16 01:39:25 +0000
committerEric Andersen <andersen@codepoet.org>2004-04-16 01:39:25 +0000
commit404e07c2e0b23409506eb3e0f57ab296ec4fa825 (patch)
tree1714463606f1f52b3a8a5f4c0b7b6526a48ee2f8 /make/ccache.mk
parent4da30416ed4a378fe698b74cd5822dc659137e73 (diff)
Stick the cache in its own empty dir
Diffstat (limited to 'make/ccache.mk')
-rw-r--r--make/ccache.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/ccache.mk b/make/ccache.mk
index ce5044469..f973a529e 100644
--- a/make/ccache.mk
+++ b/make/ccache.mk
@@ -21,8 +21,9 @@ $(CCACHE_DIR1)/.unpacked: $(DL_DIR)/$(CCACHE_SOURCE)
$(CCACHE_DIR1)/.patched: $(CCACHE_DIR1)/.unpacked
$(SED) "s,getenv(\"CCACHE_PATH\"),\"$(STAGING_DIR)/usr/bin\",g" \
$(CCACHE_DIR1)/execute.c
- $(SED) "s,getenv(\"CCACHE_DIR\"),\"$(CCACHE_DIR1)\",g" \
+ $(SED) "s,getenv(\"CCACHE_DIR\"),\"$(CCACHE_DIR1)/cache\",g" \
$(CCACHE_DIR1)/ccache.c
+ mkdir -p $(CCACHE_DIR1)/cache
touch $(CCACHE_DIR1)/.patched
$(CCACHE_DIR1)/.configured: $(CCACHE_DIR1)/.patched