summaryrefslogtreecommitdiff
path: root/make/dnsmasq.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-09-09 10:50:57 +0000
commit3d2c3c76a1cff591bc38a0971b30ee7e4ab9d9ee (patch)
tree935da51d77ee95870a094a5ae927b52c2c56cd48 /make/dnsmasq.mk
parent7e7644913a5530adab36489fd8c499f34de7eac2 (diff)
Patch by michael tesch <tesch1@gmail.com> ...
The real problem, only caused when you have a *.patch file in the main build directory, is that the Makefiles don't escape the globbing operator they're passing to patch-kernel.sh. Attached is a patch to fix that.
Diffstat (limited to 'make/dnsmasq.mk')
-rw-r--r--make/dnsmasq.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/dnsmasq.mk b/make/dnsmasq.mk
index 7944d6211..c59204992 100644
--- a/make/dnsmasq.mk
+++ b/make/dnsmasq.mk
@@ -23,7 +23,7 @@ $(DL_DIR)/$(DNSMASQ_SOURCE):
$(DNSMASQ_DIR)/.source: $(DL_DIR)/$(DNSMASQ_SOURCE)
zcat $(DL_DIR)/$(DNSMASQ_SOURCE) | tar -C $(BUILD_DIR) -xvf -
$(SOURCE_DIR)/patch-kernel.sh $(DNSMASQ_DIR) $(SOURCE_DIR) \
- $(DNSMASQ_VER)-*.patch
+ $(DNSMASQ_VER)-\*.patch
touch $(DNSMASQ_DIR)/.source
$(DNSMASQ_DIR)/$(DNSMASQ_BINARY): $(DNSMASQ_DIR)/.source