summaryrefslogtreecommitdiff
path: root/make/findutils.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
committerEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
commitfc686e3dfe3228bf420e57cee98bc61902d1187b (patch)
tree7d0931acd0179be45ae22a8405069770fca78c65 /make/findutils.mk
parent0af92f5e6f57ad00c8e4af266919387daab02227 (diff)
Fixup the "older than" (test -ot) tests for older bash
versions when one of the files is missing
Diffstat (limited to 'make/findutils.mk')
-rw-r--r--make/findutils.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/findutils.mk b/make/findutils.mk
index aaac14eaa..111a5ef0d 100644
--- a/make/findutils.mk
+++ b/make/findutils.mk
@@ -51,7 +51,8 @@ $(FINDUTILS_DIR)/$(FINDUTILS_BINARY): $(FINDUTILS_DIR)/.configured
findutils-target_binary: $(FINDUTILS_DIR)/$(FINDUTILS_BINARY)
@if [ -L $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) -ot $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) ] ; then \
+ @if [ ! -f $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) -o $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) \
+ -ot $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) ] ; then \
set -x; \
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(FINDUTILS_DIR) install; \
$(STRIP) $(TARGET_DIR)/usr/lib/locate/* > /dev/null 2>&1; \