summaryrefslogtreecommitdiff
path: root/make/findutils.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
commit1fc3f2f3de0f731c2869a48f951557eed6704218 (patch)
treee5fa011e92f78d0feab200dde260ba21561e76d0 /make/findutils.mk
parent36830baea210bba2490f643a1d147bf9adb2b62b (diff)
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'make/findutils.mk')
-rw-r--r--make/findutils.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/make/findutils.mk b/make/findutils.mk
index 540965e5e..ca204c19b 100644
--- a/make/findutils.mk
+++ b/make/findutils.mk
@@ -18,15 +18,16 @@ findutils-source: $(DL_DIR)/$(FINDUTILS_SOURCE)
$(FINDUTILS_DIR)/.unpacked: $(DL_DIR)/$(FINDUTILS_SOURCE)
$(FINDUTILS_CAT) $(DL_DIR)/$(FINDUTILS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
mv $(FINDUTILS_DIR).orig $(FINDUTILS_DIR)
- (cd $(FINDUTILS_DIR); perl -i -p -e "s,# define mbstate_t int,# define mbstate_t int\n\
- # define wchar_t char,;" $(FINDUTILS_DIR)/lib/quotearg.c)
touch $(FINDUTILS_DIR)/.unpacked
$(FINDUTILS_DIR)/.configured: $(FINDUTILS_DIR)/.unpacked
(cd $(FINDUTILS_DIR); rm -rf config.cache; \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ $(TARGET_CONFIGURE_OPTS) \
+ ac_cv_func_setvbuf_reversed=no \
./configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \