summaryrefslogtreecommitdiff
path: root/make/gdb.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
commit1fc3f2f3de0f731c2869a48f951557eed6704218 (patch)
treee5fa011e92f78d0feab200dde260ba21561e76d0 /make/gdb.mk
parent36830baea210bba2490f643a1d147bf9adb2b62b (diff)
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'make/gdb.mk')
-rw-r--r--make/gdb.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/make/gdb.mk b/make/gdb.mk
index 0cbcd9297..e696b65ec 100644
--- a/make/gdb.mk
+++ b/make/gdb.mk
@@ -19,10 +19,7 @@ $(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE) $(GDB_PATCH)
$(GDB_DIR)/.configured: $(GDB_DIR)/.unpacked
(cd $(GDB_DIR); rm -rf config.cache; \
- AR=$(TARGET_CROSS)ar \
- AS=$(TARGET_CROSS)as LD=$(TARGET_CROSS)ld \
- RANLIB=$(TARGET_CROSS)ranlib NM=$(TARGET_CROSS)nm \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ $(TARGET_CONFIGURE_OPTS) \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \