summaryrefslogtreecommitdiff
path: root/make/gdbserver.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
committerEric Andersen <andersen@codepoet.org>2003-03-04 19:16:19 +0000
commit1fc3f2f3de0f731c2869a48f951557eed6704218 (patch)
treee5fa011e92f78d0feab200dde260ba21561e76d0 /make/gdbserver.mk
parent36830baea210bba2490f643a1d147bf9adb2b62b (diff)
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'make/gdbserver.mk')
-rw-r--r--make/gdbserver.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/make/gdbserver.mk b/make/gdbserver.mk
index bafd4d9e1..103184cef 100644
--- a/make/gdbserver.mk
+++ b/make/gdbserver.mk
@@ -12,12 +12,10 @@ GDB_WDIR:=$(BUILD_DIR)/gdbserver
$(GDB_WDIR)/.configured: $(GDB_DIR)/.unpacked
mkdir -p $(GDB_WDIR)
(cd $(GDB_WDIR); rm -rf config.cache; \
- AR=$(TARGET_CROSS)ar \
- AS=$(TARGET_CROSS)as LD=$(TARGET_CROSS)ld \
- RANLIB=$(TARGET_CROSS)ranlib NM=$(TARGET_CROSS)nm \
- PATH=$(TARGET_PATH) CC=$(TARGET_CC) \
+ $(TARGET_CONFIGURE_OPTS) \
$(GDB_DIR)/gdb/gdbserver/configure \
--target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \