summaryrefslogtreecommitdiff
path: root/make/grep.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
committerEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
commitfc686e3dfe3228bf420e57cee98bc61902d1187b (patch)
tree7d0931acd0179be45ae22a8405069770fca78c65 /make/grep.mk
parent0af92f5e6f57ad00c8e4af266919387daab02227 (diff)
Fixup the "older than" (test -ot) tests for older bash
versions when one of the files is missing
Diffstat (limited to 'make/grep.mk')
-rw-r--r--make/grep.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/grep.mk b/make/grep.mk
index 8fccf5be0..9ccfa4826 100644
--- a/make/grep.mk
+++ b/make/grep.mk
@@ -51,7 +51,8 @@ $(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
@if [ -L $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) -ot $(GNUGREP_DIR)/$(GNUGREP_BINARY) ] ; then \
+ @if [ ! -f $(GNUGREP_DIR)/$(GNUGREP_BINARY) -o $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) \
+ -ot $(GNUGREP_DIR)/$(GNUGREP_BINARY) ] ; then \
set -x; \
rm -f $(TARGET_DIR)/bin/grep $(TARGET_DIR)/bin/egrep $(TARGET_DIR)/bin/fgrep; \
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \