summaryrefslogtreecommitdiff
path: root/make/hotplug.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
commit7129da009cc72575a84a30c4587bd99f745c49d4 (patch)
tree5c16654726d0b4c230ed957f88fd1b26be805171 /make/hotplug.mk
parentf7070772fa2fef125169853747ff9aecc4a88962 (diff)
Merge a bunch of stuff over from the tuxscreen buildroot, with
many updates to make things be more consistant. -Erik
Diffstat (limited to 'make/hotplug.mk')
-rw-r--r--make/hotplug.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/make/hotplug.mk b/make/hotplug.mk
new file mode 100644
index 000000000..2c3428d98
--- /dev/null
+++ b/make/hotplug.mk
@@ -0,0 +1,39 @@
+#############################################################
+#
+# hotplug support
+#
+#############################################################
+HOTPLUG_SOURCE=diethotplug-0.4.tar.gz
+HOTPLUG_SITE=http://telia.dl.sourceforge.net/sourceforge/linux-hotplug
+HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-0.4
+HOTPLUG_PATCH=$(SOURCE_DIR)/hotplug.patch
+
+$(DL_DIR)/$(HOTPLUG_SOURCE):
+ $(WGET) -P $(DL_DIR) $(HOTPLUG_SITE)/$(HOTPLUG_SOURCE)
+
+$(HOTPLUG_DIR): $(DL_DIR)/$(HOTPLUG_SOURCE) $(HOTPLUG_PATCH)
+ zcat $(DL_DIR)/$(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ cat $(HOTPLUG_PATCH) | patch -p1 -d $(HOTPLUG_DIR)
+
+$(HOTPLUG_DIR)/hotplug: $(HOTPLUG_DIR)
+ $(MAKE) CROSS=$(TARGET_CROSS) DEBUG=false KLIBC=false \
+ KERNEL_INCLUDE_DIR=$(STAGING_DIR)/include \
+ TARGET_DIR=$(TARGET_DIR) -C $(HOTPLUG_DIR);
+ $(STRIP) $(HOTPLUG_DIR)/hotplug;
+ touch -c $(HOTPLUG_DIR)/hotplug
+
+$(TARGET_DIR)/sbin/hotplug: $(HOTPLUG_DIR)/hotplug
+ cp $(HOTPLUG_DIR)/hotplug $(TARGET_DIR)/sbin/hotplug;
+ touch -c $(TARGET_DIR)/sbin/hotplug
+
+hotplug: uclibc $(TARGET_DIR)/sbin/hotplug
+
+ext2root-source: $(DL_DIR)/$(HOTPLUG_SOURCE)
+
+hotplug-clean:
+ rm -f $(TARGET_DIR)/sbin/hotplug
+ -$(MAKE) -C $(HOTPLUG_DIR) clean
+
+hotplug-dirclean:
+ rm -rf $(HOTPLUG_DIR)
+