summaryrefslogtreecommitdiff
path: root/make/hotplug.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /make/hotplug.mk
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'make/hotplug.mk')
-rw-r--r--make/hotplug.mk39
1 files changed, 0 insertions, 39 deletions
diff --git a/make/hotplug.mk b/make/hotplug.mk
deleted file mode 100644
index e13a6025d..000000000
--- a/make/hotplug.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-#############################################################
-#
-# hotplug support
-#
-#############################################################
-HOTPLUG_SOURCE=diethotplug-0.4.tar.gz
-HOTPLUG_SITE=http://aleron.dl.sourceforge.net/sourceforge/linux-hotplug
-HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-0.4
-HOTPLUG_PATCH=$(SOURCE_DIR)/hotplug.patch
-
-$(DL_DIR)/$(HOTPLUG_SOURCE):
- $(WGET) -P $(DL_DIR) $(HOTPLUG_SITE)/$(HOTPLUG_SOURCE)
-
-$(HOTPLUG_DIR): $(DL_DIR)/$(HOTPLUG_SOURCE) $(HOTPLUG_PATCH)
- zcat $(DL_DIR)/$(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- cat $(HOTPLUG_PATCH) | patch -p1 -d $(HOTPLUG_DIR)
-
-$(HOTPLUG_DIR)/hotplug: $(HOTPLUG_DIR)
- $(MAKE) CROSS=$(TARGET_CROSS) DEBUG=false KLIBC=false \
- KERNEL_INCLUDE_DIR=$(STAGING_DIR)/include \
- TARGET_DIR=$(TARGET_DIR) -C $(HOTPLUG_DIR);
- $(STRIP) $(HOTPLUG_DIR)/hotplug;
- touch -c $(HOTPLUG_DIR)/hotplug
-
-$(TARGET_DIR)/sbin/hotplug: $(HOTPLUG_DIR)/hotplug
- cp $(HOTPLUG_DIR)/hotplug $(TARGET_DIR)/sbin/hotplug;
- touch -c $(TARGET_DIR)/sbin/hotplug
-
-hotplug: uclibc $(TARGET_DIR)/sbin/hotplug
-
-hotplug-source: $(DL_DIR)/$(HOTPLUG_SOURCE)
-
-hotplug-clean:
- rm -f $(TARGET_DIR)/sbin/hotplug
- -$(MAKE) -C $(HOTPLUG_DIR) clean
-
-hotplug-dirclean:
- rm -rf $(HOTPLUG_DIR)
-