summaryrefslogtreecommitdiff
path: root/make/iproute2.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /make/iproute2.mk
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'make/iproute2.mk')
-rw-r--r--make/iproute2.mk47
1 files changed, 0 insertions, 47 deletions
diff --git a/make/iproute2.mk b/make/iproute2.mk
deleted file mode 100644
index 4aa840585..000000000
--- a/make/iproute2.mk
+++ /dev/null
@@ -1,47 +0,0 @@
-#############################################################
-#
-# iproute2
-#
-#############################################################
-IPROUTE2_VER:=2.6.9
-IPROUTE2_STAMP:=ss040831
-IPROUTE2_SOURCE:=iproute2-$(IPROUTE2_VER)-$(IPROUTE2_STAMP).tar.gz
-IPROUTE2_SITE:=http://developer.osdl.org/dev/iproute2/download/
-IPROUTE2_DIR:=$(BUILD_DIR)/iproute2-$(IPROUTE2_VER)
-IPROUTE2_CAT:=zcat
-IPROUTE2_BINARY:=tc/tc
-IPROUTE2_TARGET_BINARY:=sbin/tc
-
-$(DL_DIR)/$(IPROUTE2_SOURCE):
- $(WGET) -P $(DL_DIR) $(IPROUTE2_SOURCE_URL)$(IPROUTE2_SOURCE)
-
-$(IPROUTE2_DIR)/.unpacked: $(DL_DIR)/$(IPROUTE2_SOURCE)
- $(IPROUTE2_CAT) $(DL_DIR)/$(IPROUTE2_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- touch $(IPROUTE2_DIR)/.unpacked
-
-$(IPROUTE2_DIR)/.configured: $(IPROUTE2_DIR)/.unpacked
- (cd $(IPROUTE2_DIR); \
- ./configure; \
- $(SED) '/TC_CONFIG_ATM/s:=.*:=n:' Config)
- touch $(IPROUTE2_DIR)/.configured
-
-$(IPROUTE2_DIR)/$(IPROUTE2_BINARY): $(IPROUTE2_DIR)/.configured
- $(MAKE) \
- -C $(IPROUTE2_DIR) \
- KERNEL_INCLUDE=$(LINUX_SOURCE_DIR)/include \
- CC=$(TARGET_CC) \
- AR=$(TARGET_CROSS)ar \
- NETEM_DIST="" \
- SUBDIRS="lib tc"
-
-$(TARGET_DIR)/$(IPROUTE2_TARGET_BINARY): $(IPROUTE2_DIR)/$(IPROUTE2_BINARY)
- install -Dc $(IPROUTE2_DIR)/$(IPROUTE2_BINARY) $(TARGET_DIR)/$(IPROUTE2_TARGET_BINARY)
-
-iproute2: $(TARGET_DIR)/$(IPROUTE2_TARGET_BINARY)
-
-iproute2-clean:
- rm -f $(TARGET_DIR)/$(IPROUTE2_TARGET_BINARY)
- -$(MAKE) -C $(IPROUTE2_DIR) clean
-
-iproute2-dirclean:
- rm -rf $(IPROUTE2_DIR)