summaryrefslogtreecommitdiff
path: root/make/mke2fs.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
commit7129da009cc72575a84a30c4587bd99f745c49d4 (patch)
tree5c16654726d0b4c230ed957f88fd1b26be805171 /make/mke2fs.mk
parentf7070772fa2fef125169853747ff9aecc4a88962 (diff)
Merge a bunch of stuff over from the tuxscreen buildroot, with
many updates to make things be more consistant. -Erik
Diffstat (limited to 'make/mke2fs.mk')
-rw-r--r--make/mke2fs.mk69
1 files changed, 69 insertions, 0 deletions
diff --git a/make/mke2fs.mk b/make/mke2fs.mk
new file mode 100644
index 000000000..38a593bc2
--- /dev/null
+++ b/make/mke2fs.mk
@@ -0,0 +1,69 @@
+#############################################################
+#
+# mke2fs
+#
+#############################################################
+MKE2FS_SOURCE=e2fsprogs-1.27.tar.gz
+MKE2FS_SITE=http://telia.dl.sourceforge.net/sourceforge/e2fsprogs
+MKE2FS_DIR=$(BUILD_DIR)/e2fsprogs-1.27
+MKE2FS_CAT:=zcat
+MKE2FS_BINARY:=misc/mke2fs
+MKE2FS_TARGET_BINARY:=sbin/mke2fs
+
+$(DL_DIR)/$(MKE2FS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(MKE2FS_SITE)/$(MKE2FS_SOURCE)
+
+mke2fs-source: $(DL_DIR)/$(MKE2FS_SOURCE)
+
+$(MKE2FS_DIR)/.unpacked: $(DL_DIR)/$(MKE2FS_SOURCE)
+ $(MKE2FS_CAT) $(DL_DIR)/$(MKE2FS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(MKE2FS_DIR)/.unpacked
+
+$(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
+ (cd $(MKE2FS_DIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --with-cc=$(TARGET_CC1) \
+ --with-linker=$(TARGET_CROSS)ld \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-elf-shlibs --disable-swapfs \
+ --disable-debugfs --disable-imager \
+ --disable-resizer --disable-fsck \
+ --without-catgets --disable-nls \
+ );
+ touch $(MKE2FS_DIR)/.configured
+
+$(MKE2FS_DIR)/$(MKE2FS_BINARY): $(MKE2FS_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC1) -C $(MKE2FS_DIR)
+ $(STRIP) $(MKE2FS_DIR)/misc/mke2fs $(MKE2FS_DIR)/misc/badblocks;
+ touch -c $(MKE2FS_DIR)/misc/mke2fs
+
+$(TARGET_DIR)/$(MKE2FS_TARGET_BINARY): $(MKE2FS_DIR)/$(MKE2FS_BINARY)
+ #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(MKE2FS_DIR) install
+ #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ # $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+ # Only install a few selected items...
+ cp -dpf $(MKE2FS_DIR)/misc/mke2fs $(TARGET_DIR)/sbin/mke2fs;
+ cp -dpf $(MKE2FS_DIR)/misc/badblocks $(TARGET_DIR)/sbin/badblocks;
+ touch -c $(TARGET_DIR)/sbin/mke2fs
+
+mke2fs: uclibc $(TARGET_DIR)/$(MKE2FS_TARGET_BINARY)
+
+mke2fs-clean:
+ #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(MKE2FS_DIR) uninstall
+ rm -f $(TARGET_DIR)/sbin/mke2fs $(TARGET_DIR)/sbin/badblocks;
+ -$(MAKE) -C $(MKE2FS_DIR) clean
+
+mke2fs-dirclean:
+ rm -rf $(MKE2FS_DIR)
+