summaryrefslogtreecommitdiff
path: root/make/mke2fs.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-19 06:07:22 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-19 06:07:22 +0000
commita9bfe856cf5b524f157cda222c8b2d07f1463be9 (patch)
tree28e6fb6223262a52d352b9a318897b5e33f26360 /make/mke2fs.mk
parentb885ae776f81c216927d5ef866ddf09b6778a49b (diff)
Change from using "TARGET_CC1" to just plan "TARGET_CC"
which is a bit more sensible.
Diffstat (limited to 'make/mke2fs.mk')
-rw-r--r--make/mke2fs.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/make/mke2fs.mk b/make/mke2fs.mk
index 38a593bc2..2d340cb84 100644
--- a/make/mke2fs.mk
+++ b/make/mke2fs.mk
@@ -21,10 +21,10 @@ $(MKE2FS_DIR)/.unpacked: $(DL_DIR)/$(MKE2FS_SOURCE)
$(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
(cd $(MKE2FS_DIR); rm -rf config.cache; \
- PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC) \
./configure \
--target=$(GNU_TARGET_NAME) \
- --with-cc=$(TARGET_CC1) \
+ --with-cc=$(TARGET_CC) \
--with-linker=$(TARGET_CROSS)ld \
--prefix=/usr \
--exec-prefix=/usr \
@@ -44,12 +44,12 @@ $(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
touch $(MKE2FS_DIR)/.configured
$(MKE2FS_DIR)/$(MKE2FS_BINARY): $(MKE2FS_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC1) -C $(MKE2FS_DIR)
+ $(MAKE) CC=$(TARGET_CC) -C $(MKE2FS_DIR)
$(STRIP) $(MKE2FS_DIR)/misc/mke2fs $(MKE2FS_DIR)/misc/badblocks;
touch -c $(MKE2FS_DIR)/misc/mke2fs
$(TARGET_DIR)/$(MKE2FS_TARGET_BINARY): $(MKE2FS_DIR)/$(MKE2FS_BINARY)
- #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(MKE2FS_DIR) install
+ #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(MKE2FS_DIR) install
#rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
# $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
# Only install a few selected items...
@@ -60,7 +60,7 @@ $(TARGET_DIR)/$(MKE2FS_TARGET_BINARY): $(MKE2FS_DIR)/$(MKE2FS_BINARY)
mke2fs: uclibc $(TARGET_DIR)/$(MKE2FS_TARGET_BINARY)
mke2fs-clean:
- #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(MKE2FS_DIR) uninstall
+ #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(MKE2FS_DIR) uninstall
rm -f $(TARGET_DIR)/sbin/mke2fs $(TARGET_DIR)/sbin/badblocks;
-$(MAKE) -C $(MKE2FS_DIR) clean