summaryrefslogtreecommitdiff
path: root/make/openssh.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-04-25 19:58:35 +0000
committerEric Andersen <andersen@codepoet.org>2003-04-25 19:58:35 +0000
commit1c8e0b4771da339d9bfe450cfb9790a342b1a345 (patch)
treec1d44b905c8dd66f97dc8dc9c73be958d719c62f /make/openssh.mk
parentfcc33c3edec41673c7a5acc79eba38efdf61388c (diff)
Patch from Bruno Randolf to fix openssh cross-compile to not
use the host system's 'strip' command and thereby break the target binaries.
Diffstat (limited to 'make/openssh.mk')
-rw-r--r--make/openssh.mk16
1 files changed, 13 insertions, 3 deletions
diff --git a/make/openssh.mk b/make/openssh.mk
index af7b12994..584111cb0 100644
--- a/make/openssh.mk
+++ b/make/openssh.mk
@@ -5,8 +5,8 @@
#############################################################
OPENSSH_SITE:=ftp://ftp.tux.org/bsd/openbsd/OpenSSH/portable/
-OPENSSH_DIR:=$(BUILD_DIR)/openssh-3.5p1
-OPENSSH_SOURCE:=openssh-3.5p1.tar.gz
+OPENSSH_DIR:=$(BUILD_DIR)/openssh-3.6.1p1
+OPENSSH_SOURCE:=openssh-3.6.1p1.tar.gz
OPENSSH_PATCH:=$(SOURCE_DIR)/openssh.patch
$(DL_DIR)/$(OPENSSH_SOURCE):
@@ -45,7 +45,17 @@ $(OPENSSH_DIR)/.configured: $(OPENSSH_DIR)/.unpacked
$(OPENSSH_DIR)/ssh: $(OPENSSH_DIR)/.configured
$(MAKE) CC=$(TARGET_CC) -C $(OPENSSH_DIR)
- -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/*.so*
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/scp
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/sftp
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/sftp-server
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh-add
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh-agent
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh-keygen
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh-keyscan
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh-keysign
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/ssh-rand-helper
+ -$(STRIP) --strip-unneeded $(OPENSSH_DIR)/sshd
$(TARGET_DIR)/usr/bin/ssh: $(OPENSSH_DIR)/ssh
$(MAKE) CC=$(TARGET_CC) DESTDIR=$(TARGET_DIR) -C $(OPENSSH_DIR) install