summaryrefslogtreecommitdiff
path: root/make/openssh.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-06-20 20:31:15 +0000
committerEric Andersen <andersen@codepoet.org>2003-06-20 20:31:15 +0000
commit7c7119fc6978ef6444751b73b5f64d2e970042aa (patch)
treeefefe86896c0c5ec122fb6bf0c9388aa7a28e211 /make/openssh.mk
parent80e368b2b874b522218f27a7e935ed106397babc (diff)
Teach openssh to configure itself and start running sshd on boot
Diffstat (limited to 'make/openssh.mk')
-rw-r--r--make/openssh.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make/openssh.mk b/make/openssh.mk
index 584111cb0..91fc741a3 100644
--- a/make/openssh.mk
+++ b/make/openssh.mk
@@ -59,6 +59,8 @@ $(OPENSSH_DIR)/ssh: $(OPENSSH_DIR)/.configured
$(TARGET_DIR)/usr/bin/ssh: $(OPENSSH_DIR)/ssh
$(MAKE) CC=$(TARGET_CC) DESTDIR=$(TARGET_DIR) -C $(OPENSSH_DIR) install
+ cp $(OPENSSH_DIR)/S50sshd $(TARGET_DIR)/etc/init.d/
+ chmod a+x $(TARGET_DIR)/etc/init.d/S50sshd
rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
openssh: $(TARGET_DIR)/usr/bin/ssh