summaryrefslogtreecommitdiff
path: root/make/pppd.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
commit4f889ada561fbdffeefa1a8327d5b8939b021685 (patch)
tree925b247ee7718930f470b2c1843cb15e80a045dd /make/pppd.mk
parent93b677ea4256da1236ae5c4a14b78010e60266d9 (diff)
automatically detect if we have a usable version of sed
installed. If not, we will now build our own version.
Diffstat (limited to 'make/pppd.mk')
-rw-r--r--make/pppd.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/make/pppd.mk b/make/pppd.mk
index cf25ac8be..217f5fae7 100644
--- a/make/pppd.mk
+++ b/make/pppd.mk
@@ -18,10 +18,10 @@ pppd-source: $(DL_DIR)/$(PPPD_SOURCE)
$(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
$(PPPD_CAT) $(DL_DIR)/$(PPPD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- sed -i -e 's/ -DIPX_CHANGE -DHAVE_MULTILINK -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
- sed -i -e 's/$(INSTALL) -s/$(INSTALL)/' $(PPPD_DIR)/*/Makefile.linux
- sed -i -e 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
- sed -i -e 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
+ $(SED) 's/ -DIPX_CHANGE -DHAVE_MULTILINK -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
+ $(SED) 's/$(INSTALL) -s/$(INSTALL)/' $(PPPD_DIR)/*/Makefile.linux
+ $(SED) 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
+ $(SED) 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
touch $(PPPD_DIR)/.unpacked
$(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked