summaryrefslogtreecommitdiff
path: root/make/tar.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /make/tar.mk
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'make/tar.mk')
-rw-r--r--make/tar.mk67
1 files changed, 0 insertions, 67 deletions
diff --git a/make/tar.mk b/make/tar.mk
deleted file mode 100644
index e0ef47e44..000000000
--- a/make/tar.mk
+++ /dev/null
@@ -1,67 +0,0 @@
-#############################################################
-#
-# tar
-#
-#############################################################
-GNUTAR_VER:=1.14
-GNUTAR_SOURCE:=tar-$(GNUTAR_VER).tar.bz2
-GNUTAR_SITE:=ftp://alpha.gnu.org/gnu/tar
-GNUTAR_DIR:=$(BUILD_DIR)/tar-$(GNUTAR_VER)
-GNUTAR_CAT:=bzcat
-GNUTAR_BINARY:=src/tar
-GNUTAR_TARGET_BINARY:=bin/tar
-
-$(DL_DIR)/$(GNUTAR_SOURCE):
- $(WGET) -P $(DL_DIR) $(GNUTAR_SITE)/$(GNUTAR_SOURCE)
-
-tar-source: $(DL_DIR)/$(GNUTAR_SOURCE)
-
-$(GNUTAR_DIR)/.unpacked: $(DL_DIR)/$(GNUTAR_SOURCE)
- $(GNUTAR_CAT) $(DL_DIR)/$(GNUTAR_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- touch $(GNUTAR_DIR)/.unpacked
-
-$(GNUTAR_DIR)/.configured: $(GNUTAR_DIR)/.unpacked
- (cd $(GNUTAR_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- );
- touch $(GNUTAR_DIR)/.configured
-
-$(GNUTAR_DIR)/$(GNUTAR_BINARY): $(GNUTAR_DIR)/.configured
- $(MAKE) -C $(GNUTAR_DIR)
-
-# This stuff is needed to work around GNU make deficiencies
-tar-target_binary: $(GNUTAR_DIR)/$(GNUTAR_BINARY)
- @if [ -L $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) ] ; then \
- rm -f $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); fi;
- @if [ ! -f $(GNUTAR_DIR)/$(GNUTAR_BINARY) -o $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) \
- -ot $(GNUTAR_DIR)/$(GNUTAR_BINARY) ] ; then \
- set -x; \
- rm -f $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); \
- cp -a $(GNUTAR_DIR)/$(GNUTAR_BINARY) $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); fi ;
-
-tar: uclibc tar-target_binary
-
-tar-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUTAR_DIR) uninstall
- -$(MAKE) -C $(GNUTAR_DIR) clean
-
-tar-dirclean:
- rm -rf $(GNUTAR_DIR)
-