summaryrefslogtreecommitdiff
path: root/make/tar.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
committerEric Andersen <andersen@codepoet.org>2003-12-20 00:01:23 +0000
commitfc686e3dfe3228bf420e57cee98bc61902d1187b (patch)
tree7d0931acd0179be45ae22a8405069770fca78c65 /make/tar.mk
parent0af92f5e6f57ad00c8e4af266919387daab02227 (diff)
Fixup the "older than" (test -ot) tests for older bash
versions when one of the files is missing
Diffstat (limited to 'make/tar.mk')
-rw-r--r--make/tar.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make/tar.mk b/make/tar.mk
index c777b58ad..2ea259c09 100644
--- a/make/tar.mk
+++ b/make/tar.mk
@@ -49,7 +49,8 @@ $(GNUTAR_DIR)/$(GNUTAR_BINARY): $(GNUTAR_DIR)/.configured
tar-target_binary: $(GNUTAR_DIR)/$(GNUTAR_BINARY)
@if [ -L $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) ] ; then \
rm -f $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); fi;
- @if [ $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) -ot $(GNUTAR_DIR)/$(GNUTAR_BINARY) ] ; then \
+ @if [ ! -f $(GNUTAR_DIR)/$(GNUTAR_BINARY) -o $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY) \
+ -ot $(GNUTAR_DIR)/$(GNUTAR_BINARY) ] ; then \
set -x; \
rm -f $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); \
cp -a $(GNUTAR_DIR)/$(GNUTAR_BINARY) $(TARGET_DIR)/$(GNUTAR_TARGET_BINARY); fi ;