summaryrefslogtreecommitdiff
path: root/make/tinyx.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
commit620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d (patch)
treeaa08afb7d58fabed8f365bf373751992b792680c /make/tinyx.mk
parent192bace39e7c0fe5c4ccf9add25b67cb37f8abdc (diff)
By popular demand, use 'sed' rather than 'perl' for doing
search and replace stuff. Hopefully we do not have any perl specific regexs that will be broken by this change, but it seems to be working thus far anyways,
Diffstat (limited to 'make/tinyx.mk')
-rw-r--r--make/tinyx.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/tinyx.mk b/make/tinyx.mk
index 9f79d2f95..984f6fa9a 100644
--- a/make/tinyx.mk
+++ b/make/tinyx.mk
@@ -75,7 +75,7 @@ $(TINYX_DIR)/.configure: $(DL_DIR)/$(TINYX_SOURCE) $(DL_DIR)/cross.def $(DL_DIR)
cat $(TINYX_PATCH) | patch -d $(TINYX_DIR) -p1
cp $(DL_DIR)/host.def $(TINYX_CF)/host.def
cp $(DL_DIR)/cross.def $(TINYX_CF)/cross.def
- perl -i -p -e 's:REPLACE_STAGING_DIR:$(STAGING_DIR):g' \
+ sed -ie 's:REPLACE_STAGING_DIR:$(STAGING_DIR):g' \
$(TINYX_CF)/cross.def \
$(TINYX_LDIR)/X11/Xlib.h
touch $(TINYX_DIR)/.configure