summaryrefslogtreecommitdiff
path: root/make/user-mode-linux.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-19 17:17:56 +0000
commit4f889ada561fbdffeefa1a8327d5b8939b021685 (patch)
tree925b247ee7718930f470b2c1843cb15e80a045dd /make/user-mode-linux.mk
parent93b677ea4256da1236ae5c4a14b78010e60266d9 (diff)
automatically detect if we have a usable version of sed
installed. If not, we will now build our own version.
Diffstat (limited to 'make/user-mode-linux.mk')
-rw-r--r--make/user-mode-linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/user-mode-linux.mk b/make/user-mode-linux.mk
index 1572cefb9..e84541c03 100644
--- a/make/user-mode-linux.mk
+++ b/make/user-mode-linux.mk
@@ -35,7 +35,7 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
touch $(LINUX_DIR)/.patched
$(LINUX_DIR)/.set_arch: $(LINUX_DIR)/.patched
- sed -i -e "s/^ARCH :=.*/ARCH:=um/g;" $(LINUX_DIR)/Makefile
+ $(SED) "s/^ARCH :=.*/ARCH:=um/g;" $(LINUX_DIR)/Makefile
touch $(LINUX_DIR)/.set_arch
$(LINUX_DIR)/.configured $(BUILD_DIR)/linux/.configured: $(LINUX_DIR)/.set_arch $(LINUX_KCONFIG)