summaryrefslogtreecommitdiff
path: root/make
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2004-03-18 06:57:20 +0000
committerManuel Novoa III <mjn3@codepoet.org>2004-03-18 06:57:20 +0000
commit2a6ec4edcdf805c7888c241940e6965f2d4f8fda (patch)
tree3f5ea0b08542fd1335a300579ae54b80b1f26ce6 /make
parent4005c7790c7792a437c459083f4ae71c5fe641a3 (diff)
Update from .39 to .41 and change to using the muilt-binary version instead
of 3 seperate binaries.
Diffstat (limited to 'make')
-rw-r--r--make/dropbear_sshd.mk28
1 files changed, 18 insertions, 10 deletions
diff --git a/make/dropbear_sshd.mk b/make/dropbear_sshd.mk
index 1362aa851..d694508f9 100644
--- a/make/dropbear_sshd.mk
+++ b/make/dropbear_sshd.mk
@@ -3,11 +3,11 @@
# dropbear_sshd
#
#############################################################
-DROPBEAR_SSHD_SOURCE:=dropbear-0.39.tar.bz2
+DROPBEAR_SSHD_SOURCE:=dropbear-0.41.tar.bz2
DROPBEAR_SSHD_SITE:=http://matt.ucc.asn.au/dropbear/releases/
-DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.39
+DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.41
DROPBEAR_SSHD_CAT:=bzcat
-DROPBEAR_SSHD_BINARY:=dropbear
+DROPBEAR_SSHD_BINARY:=dropbearmulti
DROPBEAR_SSHD_TARGET_BINARY:=usr/sbin/dropbear
@@ -19,6 +19,7 @@ dropbear_sshd-source: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
$(DROPBEAR_SSHD_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
$(DROPBEAR_SSHD_CAT) $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
$(SOURCE_DIR)/patch-kernel.sh $(DROPBEAR_SSHD_DIR) $(SOURCE_DIR) dropbear-*.patch
+ $(SED) 's,^/\* #define DROPBEAR_MULTI.*,#define DROPBEAR_MULTI,g' $(DROPBEAR_SSHD_DIR)/options.h
touch $(DROPBEAR_SSHD_DIR)/.unpacked
$(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
@@ -46,19 +47,26 @@ $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
touch $(DROPBEAR_SSHD_DIR)/.configured
$(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
- $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR)
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
+ -C $(DROPBEAR_SSHD_DIR) dropbearmulti
$(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
- $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
- -C $(DROPBEAR_SSHD_DIR) install
- rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
- $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+ #$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
+ # LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) install
+ #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ # $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+ install -d -m 755 $(TARGET_DIR)/usr/sbin
+ install -d -m 755 $(TARGET_DIR)/usr/bin
+ install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
+ $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+ ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
+ ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
dropbear_sshd: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
dropbear_sshd-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
- -C $(DROPBEAR_SSHD_DIR) uninstall
+ $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
+ LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) uninstall
-$(MAKE) -C $(DROPBEAR_SSHD_DIR) clean
dropbear_sshd-dirclean: