summaryrefslogtreecommitdiff
path: root/make
diff options
context:
space:
mode:
authorRobert Griebl <griebl@gmx.de>2004-03-13 00:01:08 +0000
committerRobert Griebl <griebl@gmx.de>2004-03-13 00:01:08 +0000
commit827f1fc21820965c53c92146432f84d14af4f081 (patch)
treed3e1d5bfc01e6b12e6285bff82cec868be2879ee /make
parent1ffd497d7e4c0d55b30dcb94a8cb92ecb9df2bad (diff)
Switch to the C locale before greping for an english text.
Diffstat (limited to 'make')
-rw-r--r--make/ext2root.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/ext2root.mk b/make/ext2root.mk
index 5171ac2ed..0c66c18a9 100644
--- a/make/ext2root.mk
+++ b/make/ext2root.mk
@@ -34,7 +34,7 @@ genext2fs: $(GENEXT2_DIR)/genext2fs
# How much KB we want to add to the calculated size for slack space
#GENEXT2_ADDTOROOTSIZE=4096
GENEXT2_ADDTOROOTSIZE=16384
-GENEXT2_REALSIZE=$(subst total,, $(shell du $(TARGET_DIR) -s -c -k | grep total ))
+GENEXT2_REALSIZE=$(subst total,, $(shell LANG=C du $(TARGET_DIR) -s -c -k | grep total ))
GENEXT2_SIZE=$(shell expr $(GENEXT2_REALSIZE) + $(GENEXT2_ADDTOROOTSIZE))
# We currently add about 400 device nodes, so add that into the total
GENEXT2_INODES=$(shell expr $(shell find $(TARGET_DIR) | wc -l) + 400)