summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorArnar Mar SigurĂ°sson <antab@valka.is>2008-06-01 17:58:48 +0000
committerArnar Mar SigurĂ°sson <antab@valka.is>2008-06-01 17:58:48 +0000
commit65063afec93970406b8529371b0519e5d2a5062d (patch)
tree1e046bf57e5775181355e272c71cd0659ef10731 /package/Makefile.autotools.in
parente7bdf94241b031ed1308a915e9a58b949d52f31f (diff)
Add option to set default site to download package source from. FreeBSD ports mirrors (like: ftp2.uk.freebsd.org/pub/FreeBSD/ports/distfiles) are a good place to find almost all of the source packages.
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index cf2ac7d23..09c30958c 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -131,6 +131,9 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
$(call MESSAGE,"Downloading")
+ifdef BR2_PRIMARY_SITE
+ -$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $(BR2_PRIMARY_SITE)/$($(PKG)_SOURCE)
+endif
$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
$(if $($(PKG)_PATCH),$(Q)test -e $(DL_DIR)/$($(PKG)_PATCH) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
$(Q)mkdir -p $(@D)