summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-02 08:58:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-02 08:58:18 +0000
commitea1eb9e9f92256c2023e51362b4365bff648530b (patch)
tree70521a1f0369c4f1f85310c45f238c5b9cfe321f /package/Makefile.autotools.in
parentec771579451c54c8590800ca1803cd6bfcc9a116 (diff)
Makefile.autotools.in: fix source handling
Handling source/source-check/external-deps together doesn't work, as wget will then download the sources every time make source is called even if it's available in DL_DIR Instead detect source-check/external-deps from MAKELEVEL. Support downloadable package patches in source-check/external-deps while we're at it.
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index ae48654e2..16fc37192 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -130,9 +130,10 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
-# support make source/source-check/external-deps
-ifneq ($(filter source,$(MAKECMDGOALS)),)
+# support make source-check/external-deps
+ifeq ($(MAKELEVEL),1)
$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
+ $(if $($(PKG)_PATCH),$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
else
$(call MESSAGE,"Downloading")
ifneq ($(strip $(subst ",,$(BR2_PRIMARY_SITE))),)