summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-30 13:42:01 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-30 13:48:02 +0100
commit073af428efc21d7717c003e93a098d0767de3b0c (patch)
treeebe37b3cdf907cb83d7eecb3e86189e1b95c3008 /package/Makefile.autotools.in
parentc63c2faf55b2eb53eda67532929f3e35419f8c40 (diff)
Makefile.autotools.in: fix libtool patching
Fixes two issues with libtool patching: - It seems like the default value for <package>_LIBTOOL_PATCH only gets set AFTER the ifdef check, so the conditional was never taken. Fix it by instead checking that it isn't explicitly set to not do the patching instead. - The $i in the libtool patching for loop needed an extra level of escaping to work. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 09f44b46f..f0f189f90 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -140,12 +140,13 @@ define LIBTOOL_PATCH_HOOK
$(Q)if test "$$($$(PKG)_LIBTOOL_PATCH)" = "YES" -a \
"$$($$(PKG)_AUTORECONF)" != "YES"; then \
for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
- toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
+ toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool.patch; \
done \
fi
endef
-ifeq ($($(2)_LIBTOOL_PATCH),YES)
+# default values are not evaluated yet, so don't rely on this defaulting to YES
+ifneq ($($(2)_LIBTOOL_PATCH),NO)
$(2)_POST_PATCH_HOOKS += LIBTOOL_PATCH_HOOK
endif