summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorHamish Moffatt <hamish@cloud.net.au>2008-09-04 01:19:52 +0000
committerHamish Moffatt <hamish@cloud.net.au>2008-09-04 01:19:52 +0000
commit18a7694675aa6f195646dfb64c94a230518edbff (patch)
tree198e9e450093f0ddf767f98eeba90f10c9062b6e /package/Makefile.autotools.in
parentfeb569d3cdbad61167df081781c2be8fb61f91f0 (diff)
Fix duplicate $(AUTORECONF) run in autoreconf and configure targets
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 480082f8b..3997e5fe3 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -192,17 +192,15 @@ endif
$(BUILD_DIR)/%/.stamp_autoconfigured:
$(call MESSAGE,"Running autoreconf")
$(Q)cd $(@D)/$($(PKG)_SUBDIR) && $(AUTORECONF)
+# if the package uses libtool, patch it for cross-compiling in buildroot
+ $(Q)for i in `find $(@D)/$($(PKG)_SUBDIR) -name ltmain.sh`; do \
+ toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
+ done
$(Q)touch $@
# Configuring
$(BUILD_DIR)/%/.stamp_configured:
$(call MESSAGE,"Configuring")
- $(Q)if test "$($(PKG)_AUTORECONF)" = "YES"; then \
- cd $(@D)/$($(PKG)_SUBDIR) && $(AUTORECONF); \
- for i in `find $(@D)/$($(PKG)_SUBDIR) -name ltmain.sh`; do \
- ../../toolchain/patch-kernel.sh $${i%/*} ../../package buildroot-libtool.patch; \
- done \
- fi
cd $(@D)/$($(PKG)_SUBDIR) && rm -f config.cache && \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \