summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-17 13:48:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-17 13:48:35 +0000
commit23e2e52df77158994a73f2e6799b0ab9dc741d36 (patch)
tree56a4d10d123a6e3597a044ee6a144cb63fbde21c /package/Makefile.autotools.in
parent00400f4720a52a0b169cb4fdd706628dc712073e (diff)
Makefile.autotools.in: use TARGET_PATH for compile step
This ensures that the correct build tools are found rather than the host versions (glib-genmarshal, ..)
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index b8abd73f3..3c0183731 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -259,7 +259,7 @@ $(BUILD_DIR)/%/.stamp_configured:
# Build
$(BUILD_DIR)/%/.stamp_built:
$(call MESSAGE,"Building")
- $($(PKG)_MAKE_ENV) $($(PKG)_MAKE) $($(PKG)_MAKE_OPT) -C $(@D)/$($(PKG)_SUBDIR)
+ PATH=$(TARGET_PATH) $($(PKG)_MAKE_ENV) $($(PKG)_MAKE) $($(PKG)_MAKE_OPT) -C $(@D)/$($(PKG)_SUBDIR)
$(Q)touch $@
# Install to staging dir