summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-20 15:08:15 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-07 08:14:41 +0200
commit26082e79af64550d16fb1e314a904456b90a464e (patch)
tree37209f8e320b1411c61bed08a2f7d326d637bd47 /package/Makefile.autotools.in
parent0ab16a01bbe02d37ad2daa007fdb5a0de0ff9eab (diff)
Introduce support for host config cache
We now have for quite some time a configuration cache used to speed-up the execution of ./configure scripts when compiling programs for the target. This commit introduces a similar concept when Buildroot compiles programs for the host. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 318bd714a..337aee488 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -117,6 +117,7 @@ define $(2)_CONFIGURE_CMDS
LDFLAGS="$$(HOST_LDFLAGS)" \
$$($$(PKG)_CONF_ENV) \
./configure \
+ $$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/host-config.cache",) \
--prefix="$$(HOST_DIR)/usr" \
--sysconfdir="$$(HOST_DIR)/etc" \
$$($$(PKG)_CONF_OPT) \