summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:43 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:12:27 +0200
commit300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49 (patch)
tree4b06e56a40777a04ec56ba16d9b5d08fed84de08 /package/Makefile.autotools.in
parent0849e8193ef429f29945b8c2a54eafc8635e0969 (diff)
package: remove useless arguments from AUTOTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the AUTOTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 4cd63a36e..3f523dc5e 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -294,15 +294,13 @@ endef
################################################################################
# AUTOTARGETS -- the target generator macro for autotools packages
#
-# Argument 1 is the package directory prefix [mandatory]
-# Argument 2 is the lowercase package name [mandatory]
-# Argument 3 is "target" or "host" [optional, default: "target"]
+# Argument 1 is "target" or "host" [optional, default: "target"]
################################################################################
define AUTOTARGETS
-ifeq ($(3),host)
-$(call AUTOTARGETS_INNER,$(3)-$(2),$(call UPPERCASE,$(3)-$(2)),$(call UPPERCASE,$(2)),$(1),host)
+ifeq ($(1),host)
+$(call AUTOTARGETS_INNER,$(1)-$(call pkgname),$(call UPPERCASE,$(1)-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
else
-$(call AUTOTARGETS_INNER,$(2),$(call UPPERCASE,$(2)),$(call UPPERCASE,$(2)),$(1),target)
+$(call AUTOTARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
endif
endef