summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorWade Berrier <wberrier@gmail.com>2008-10-06 19:20:58 +0000
committerWade Berrier <wberrier@gmail.com>2008-10-06 19:20:58 +0000
commit56eebd08c050eaea2c2844c1fd01f03946d457e3 (patch)
treee5b1024bf34b493217c3125d4eb7f8ea3e4c35ca /package/Makefile.autotools.in
parent6afbfedbb4407945a98c3ef5fd02790bea040832 (diff)
Makefile.autotools.in:
-Make tar switches 1.14 compatible (Not sure of a more elegant way to handle this ... ?)
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 9c1697282..8294ebfa6 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -124,6 +124,8 @@ TAR ?= tar
#AUTORECONF ?= autoreconf -v -i -f -I $(ACLOCAL_STAGING_DIR)
# ACLOCAL="$(ACLOCAL)"
+# Automatically detect tar --strip-path/components option
+TAR_STRIP_COMPONENTS = $(shell tar --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi)
################################################################################
# Implicit targets -- produce a stamp file for each step of a package build
@@ -152,7 +154,7 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(call MESSAGE,"Extracting")
$(Q)mkdir -p $(@D)
$(Q)$(INFLATE$(suffix $($(PKG)_SOURCE))) $(DL_DIR)/$($(PKG)_SOURCE) | \
- $(TAR) --strip-components=1 -C $(@D) $(TAR_OPTIONS) -
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
# some packages have messed up permissions inside
$(Q)chmod -R ug+rw $(@D)
$(Q)touch $@