summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorWade Berrier <wberrier@gmail.com>2008-10-07 17:08:27 +0000
committerWade Berrier <wberrier@gmail.com>2008-10-07 17:08:27 +0000
commit5b0e7a5ddb4b7a03ff0ef7552f09970d6422f9c7 (patch)
tree217656c89a1c9adcf8acbcd513e400f17e665800 /package/Makefile.autotools.in
parenta8ed074e80dcfe13c0061628a1243c5e640e3e20 (diff)
Makefile.autotools.in: honor CONFIG_SHELL and TAR.
Don't use recursively expanded definition (Use ':=' instead of '=')
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 8294ebfa6..076006300 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -125,7 +125,7 @@ TAR ?= tar
# ACLOCAL="$(ACLOCAL)"
# Automatically detect tar --strip-path/components option
-TAR_STRIP_COMPONENTS = $(shell tar --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi)
+TAR_STRIP_COMPONENTS := $(shell $(CONFIG_SHELL) -c '$(TAR) --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi')
################################################################################
# Implicit targets -- produce a stamp file for each step of a package build