summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-01 21:20:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-01 21:20:35 +0000
commit69f8592407635cc7b36aebac692e24a02b046aab (patch)
tree45744fac12f296318e2bbf7e234b6a58fb0da9f3 /package/Makefile.autotools.in
parentae6011eb3360be00b2c72b98faea6398c418770a (diff)
buildroot: set SHELL instead of messing around with CONFIG_SHELL
Simply set SHELL to bash instead of adding CONFIG_SHELL to all shell invocations. CONFIG_SHELL is still set, as it is used by kconfig.
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index ce6ad0f8f..6ed9c31fe 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -127,7 +127,7 @@ TAR ?= tar
# ACLOCAL="$(ACLOCAL)"
# Automatically detect tar --strip-path/components option
-TAR_STRIP_COMPONENTS := $(shell $(CONFIG_SHELL) -c '$(TAR) --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi')
+TAR_STRIP_COMPONENTS := $(shell $(TAR) --help | grep strip-path > /dev/null ; if test $$? = 0 ; then echo '--strip-path' ; else echo '--strip-components' ; fi)
################################################################################
# Implicit targets -- produce a stamp file for each step of a package build