summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-01-16 14:58:35 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-17 23:28:47 +0100
commitbbc53fa8446a4106eb666310f19a9bfbd0b4f3c7 (patch)
tree90a62e037cc29d0578e609bfc6158290c44200dc /package/Makefile.autotools.in
parentfcc7cd3c7b42a2ff829a0cf7d28894cff3a89660 (diff)
package: derive HOST_FOO_DEPENDENCIES from FOO_DEPENDENCIES
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index c84afa0b1..495a07580 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -200,6 +200,16 @@ define AUTORECONF_HOOK
fi
endef
+# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
+# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
+# away from the non-host rule
+ifndef $(2)_DEPENDENCIES
+ ifdef $(3)_DEPENDENCIES
+ $(2)_DEPENDENCIES = $(filter-out host-automake host-autoconf host-libtool,\
+ $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
+ endif
+endif
+
ifeq ($$($(2)_AUTORECONF),YES)
$(2)_PRE_CONFIGURE_HOOKS += AUTORECONF_HOOK
$(2)_DEPENDENCIES += host-automake host-autoconf host-libtool