summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-01-18 14:53:06 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-01-18 14:53:06 +0100
commitecf5939cfb394289cb275134e2929b5d9076628d (patch)
tree37d8392c535961a7dab5b01f986631d28091ca6f /package/Makefile.autotools.in
parent59493977cb8c49d4d6bbdba80c79e678f0fab446 (diff)
Makefile.autotools.in: fixup .la files in all lib dirs
Sometimes usr/lib32 or usr/lib64 is used instead of usr/lib, so search those for .la files as well. Fixes .la fixup for beecrypt on x86-64. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index f0f189f90..7114bbab3 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -201,7 +201,7 @@ endif
ifndef $(2)_INSTALL_STAGING_CMDS
define $(2)_INSTALL_STAGING_CMDS
$$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
- for i in $$$$(find $(STAGING_DIR)/usr/lib/ -name "*.la"); do \
+ for i in $$$$(find $(STAGING_DIR)/usr/lib* -name "*.la"); do \
cp $$$$i $$$$i~; \
$$(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$$$i; \
done