summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-11-08 18:37:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-15 18:09:23 +0100
commite11fe847b2f545446fc3300dd2ba88fd5da05756 (patch)
treeb9121f06c5d1bb0203439d266004d4a6ec61ed4e /package/Makefile.in
parentf3f1a94313361c251c4dfa164921d475835c763d (diff)
Add generic package infrastructure
This new infrastructure allows to write simpler .mk files for packages not using the autotools as their build system, by factorizing many common steps (download, extract, patching), and will more easily allow Buildroot-wide changes in how the packages are handled. The main macro is called GENTARGETS and works similarly to the AUTOTARGETS macro that already exists for autotools-based packages. However, the set of variables to be defined before calling the macro is different. Refer to the documentation for details. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 25dd6da81..8edd1934f 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -349,3 +349,4 @@ endif
X11_PREFIX:=$(call qstrip,$(BR2_X11_PREFIX))
include package/Makefile.autotools.in
+include package/Makefile.package.in