summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorMalte Starostik <m-starostik@versanet.de>2010-07-18 22:16:48 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-18 22:46:06 +0200
commit0383d48a5e61db900171ae74d4d2dfe30c420d04 (patch)
tree8753d0aa8a70196f49b395f202f0b53dc081cdb5 /package/Makefile.package.in
parentad36fcdda0de654e7da5ba84015b92e48a576e69 (diff)
Match whole words when changing .config options
Make KCONFIG_{ENABLE,DISABLE,SET}_OPT match whole words only. Fixes that BR_INET_IPV6 enables CONFIG_IPV6 in the kernel's .config, but also nukes everything with "CONFIG_IPV6" in its name, e.g. CONFIG_IPV6_PRIVACY. This in turn causes any IPv6 options in a custom kernel .config to be lost and oldconfig going interactive. Signed-off-by: Malte Starostik <m-starostik@versanet.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index c476de98d..d76b7913d 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -41,17 +41,17 @@ UPPERCASE = $(strip $(eval __tmp := $1) \
$(__tmp))
define KCONFIG_ENABLE_OPT
- $(SED) "/$(1)/d" $(2)
+ $(SED) "/\\<$(1)\\>/d" $(2)
echo "$(1)=y" >> $(2)
endef
define KCONFIG_SET_OPT
- $(SED) "/$(1)/d" $(3)
+ $(SED) "/\\<$(1)\\>/d" $(3)
echo "$(1)=$(2)" >> $(3)
endef
define KCONFIG_DISABLE_OPT
- $(SED) "/$(1)/d" $(2)
+ $(SED) "/\\<$(1)\\>/d" $(2)
echo "# $(1) is not set" >> $(2)
endef