summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorMaxime Petazzoni <maxime.petazzoni@bulix.org>2010-09-02 12:09:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-13 08:17:46 +0200
commit07b2af1a45c5276125b54d64f839fdcd660d602d (patch)
tree6de406ce4e6a17306e0bf7f1ade4fff95e0c6b7a /package/Makefile.package.in
parent33070528796dafe90ebab836356fea03f2dc24f9 (diff)
Remove the spider feature
In preparation for the re-work of the DOWNLOAD helper to support multiple download methods and protocols, the spider feature used with wget is removed for now until it is re-implemented on top of the new download methods. Signed-off-by: Maxime Petazzoni <maxime.petazzoni@bulix.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index d76b7913d..ba0fd8433 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -81,16 +81,11 @@ TERM_RESET := $(shell tput rmso)
# $(call DOWNLOAD,$(FOO_SITE),$(FOO_SOURCE))
################################################################################
-# support make source-check/external-deps
-ifneq ($(SPIDER),)
-DOWNLOAD=$(WGET) -P $(DL_DIR) $(1)/$(2)
-else
define DOWNLOAD
$(Q)test -e $(DL_DIR)/$(2) || \
for site in $(call qstrip,$(BR2_PRIMARY_SITE)) $(1) $(call qstrip,$(BR2_BACKUP_SITE)); \
do $(WGET) -P $(DL_DIR) $$site/$(2) && exit; done
endef
-endif
# Utility programs used to build packages
TAR ?= tar
@@ -117,19 +112,14 @@ endef
# Retrieve the archive
$(BUILD_DIR)/%/.stamp_downloaded:
-# support make source-check/external-deps
-ifeq ($(SPIDER),)
# Only show the download message if it isn't already downloaded
$(Q)(test -e $(DL_DIR)/$($(PKG)_SOURCE) && \
(test -z $($(PKG)_PATCH) || test -e $(DL_DIR)$($(PKG)_PATCH))) || \
$(call MESSAGE,"Downloading")
-endif
$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_SOURCE))
$(if $($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_PATCH)))
-ifeq ($(SPIDER),)
$(Q)mkdir -p $(@D)
$(Q)touch $@
-endif
# Unpack the archive
$(BUILD_DIR)/%/.stamp_extracted: